import Foundation
let pattern = #"^(((\+|0{2})\s?[1-9]\d{0,2})(\s?(\-\s?)?)\(?|0|\()(0\))?(0?[1-9](\d{1,4}?|(\d{1,2}\s\d{1,3})))(\s?(\-\s?)?)(\d{2,4}?\s?(\d{2,3}\s)?\d{2,5})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
^(((\+|0{2})\s?[1-9]\d{0,2})(\s?(\-\s?)?)\(?|0|\()
(0\))?
(0?[1-9](\d{1,4}?|(\d{1,2}\s\d{1,3})))
(\s?(\-\s?)?)
(\d{2,4}?\s?(\d{2,3}\s)?\d{2,5})$
+11 89-123 12 12
+11 89 123 1234
+11 089 1234567
+11 789 123 123
+11 0789 123456
+11 89 1234567
+11 0123456789
00123456789012
0012345678901
+11 123456789
+123456789012
+12345678901
0789-123456
089-1234567
089 1234567
0123456789
0789 123456
00110 (0)789 1234567
0011(0)7891234567
0011 (0)7891234567
+11 (0)89 1234567
+11 (0)789 123456
+11 (0)123456789
0789-123456
089-1234567
089 1234567
0123456789
(0)789 123456
0(0)789 123456
001(0)789 123456
+1(0)789 123456
+11 79887 123456
+11 7988 7 123456
+11 798 87 123456
+11 79 887 123456
+11 7 9887 123456
+11789123456
00117891234567
+11 789 123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)