#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\+|0{2})\s?[1-9]\d{0,2})(\s?(\-\s?)?)\(?|0|\()(0\))?(0?[1-9](\d{1,4}?|(\d{1,2}\s\d{1,3})))(\s?(\-\s?)?)(\d{2,4}?\s?(\d{2,3}\s)?\d{2,5})$"
Local $sString = "^(((\+|0{2})\s?[1-9]\d{0,2})(\s?(\-\s?)?)\(?|0|\()" & @CRLF & _
"(0\))?" & @CRLF & _
"(0?[1-9](\d{1,4}?|(\d{1,2}\s\d{1,3})))" & @CRLF & _
"(\s?(\-\s?)?)" & @CRLF & _
"(\d{2,4}?\s?(\d{2,3}\s)?\d{2,5})$" & @CRLF & _
"" & @CRLF & _
"+11 89-123 12 12" & @CRLF & _
"+11 89 123 1234" & @CRLF & _
"+11 089 1234567" & @CRLF & _
"+11 789 123 123" & @CRLF & _
"+11 0789 123456" & @CRLF & _
"+11 89 1234567" & @CRLF & _
"+11 0123456789" & @CRLF & _
"00123456789012" & @CRLF & _
"0012345678901" & @CRLF & _
"+11 123456789" & @CRLF & _
"+123456789012" & @CRLF & _
"+12345678901" & @CRLF & _
"0789-123456" & @CRLF & _
"089-1234567" & @CRLF & _
"089 1234567" & @CRLF & _
"0123456789" & @CRLF & _
"" & @CRLF & _
"0789 123456" & @CRLF & _
"" & @CRLF & _
"00110 (0)789 1234567" & @CRLF & _
"0011(0)7891234567" & @CRLF & _
"0011 (0)7891234567" & @CRLF & _
"" & @CRLF & _
"+11 (0)89 1234567" & @CRLF & _
"+11 (0)789 123456" & @CRLF & _
"+11 (0)123456789" & @CRLF & _
"0789-123456" & @CRLF & _
"089-1234567" & @CRLF & _
"089 1234567" & @CRLF & _
"0123456789" & @CRLF & _
"" & @CRLF & _
"(0)789 123456" & @CRLF & _
"0(0)789 123456" & @CRLF & _
"001(0)789 123456" & @CRLF & _
"+1(0)789 123456" & @CRLF & _
"" & @CRLF & _
"+11 79887 123456" & @CRLF & _
"+11 7988 7 123456" & @CRLF & _
"+11 798 87 123456" & @CRLF & _
"+11 79 887 123456" & @CRLF & _
"+11 7 9887 123456" & @CRLF & _
"" & @CRLF & _
"+11789123456" & @CRLF & _
"00117891234567" & @CRLF & _
"+11 789 123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")