$re = '/\[([^\[\]]*?)\]\((\S*?)\)/si';
$str = '# Basic Cases
[test link](http://test.com)
[test-link@test.com](http://test.com/test-link)
[title (parenthesis)](http://www.test.com)
[relative link](/test-link/page)
[anchor reference](#reference)
[title with
linebreak](http://test.com)
# Extra Cases
[]()
[](uri:empty-title)
[[extra sq bracket](ftp://test.com)
[extra sq bracket - invalid]](https://test.com)
[extra parentheses](((())))
[link with linebreak - invalid](http:
//test.com)
# Lazy Delimiter Testing
[()][()][(][)[][]))([()[(((][(]][)([(])))[()
[((()))]()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);