import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\[\\]]*?)\\]\\((\\S*?)\\)";
final String string = "# Basic Cases\n\n"
+ "[test link](http://test.com)\n\n"
+ "[test-link@test.com](http://test.com/test-link)\n\n"
+ "[title (parenthesis)](http://www.test.com)\n\n"
+ "[relative link](/test-link/page)\n\n"
+ "[anchor reference](#reference)\n\n"
+ "[title with\n"
+ "linebreak](http://test.com)\n\n"
+ "# Extra Cases\n\n"
+ "[]()\n\n"
+ "[](uri:empty-title)\n\n"
+ "[[extra sq bracket](ftp://test.com)\n\n"
+ "[extra sq bracket - invalid]](https://test.com)\n\n"
+ "[extra parentheses](((())))\n\n"
+ "[link with linebreak - invalid](http:\n"
+ "//test.com)\n\n"
+ "# Lazy Delimiter Testing\n\n"
+ "[()][()][(][)[][]))([()[(((][(]][)([(])))[()\n\n"
+ "[((()))]()\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}