$re = '/(\d+\.?)/';
$str = 'openrecovery-twrp-2.6.3.0-ace.img';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);