package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\.?)`)
var str = `openrecovery-twrp-2.6.3.0-ace.img`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}