import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<h3 id=\\\"title\\\" class=\\\"mb-0 mt-0\\\"\\>)(\\<\\?php echo L10n::icon\\(')(.*?)('\\); \\?>)(\\<\\?php echo L10n::message\\('label.)(.*?)(', )(L10n::label\\()(.*?)(\\); \\?>)(\\<\\/h3>)";
final String string = "<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('camera'); ?><?php echo L10n::message('label.add', L10n::label('camera')); ?></h3>\n"
+ " <h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('bookmark'); ?><?php echo L10n::message('label.add', L10n::label('bookmark')); ?></h3>\n"
+ "<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.add', L10n::label('dashboard')); ?></h3>\n"
+ "<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.edit', L10n::label('dashboard')); ?></h3>";
final String subst = "$1$2$3$4<?php echo L10n::label($7)$8$9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}