using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<h3 id=\""title\"" class=\""mb-0 mt-0\""\>)(\<\?php echo L10n::icon\(')(.*?)('\); \?>)(\<\?php echo L10n::message\('label.)(.*?)(', )(L10n::label\()(.*?)(\); \?>)(\<\/h3>)";
string substitution = @"$1$2$3$4<?php echo L10n::label($7)$8$9";
string input = @"<h3 id=""title"" class=""mb-0 mt-0""><?php echo L10n::icon('camera'); ?><?php echo L10n::message('label.add', L10n::label('camera')); ?></h3>
<h3 id=""title"" class=""mb-0 mt-0""><?php echo L10n::icon('bookmark'); ?><?php echo L10n::message('label.add', L10n::label('bookmark')); ?></h3>
<h3 id=""title"" class=""mb-0 mt-0""><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.add', L10n::label('dashboard')); ?></h3>
<h3 id=""title"" class=""mb-0 mt-0""><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.edit', L10n::label('dashboard')); ?></h3>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}