$re = '/(?<=v=|v\/|embed\/|be\/)([^&?]+)/';
$str = 'https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);