using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=v=|v\/|embed\/|be\/)([^&?]+)";
string input = @"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}