$re = '/([0-9]+)(?:\')/m';
$str = '=if(D3<>"",if(iferror(regexmatch(D3,"([0-9]+)(?:\')"),false)=true,REGEXEXTRACT(D3,"([0-9]+)(?:\')")*12+REGEXEXTRACT(D3,"([0-9]+)(?:"&char(34)&")"),D3*12),"")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);