using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+)(?:')";
string input = @"=if(D3<>"",if(iferror(regexmatch(D3,""([0-9]+)(?:')""),false)=true,REGEXEXTRACT(D3,""([0-9]+)(?:')"")*12+REGEXEXTRACT(D3,""([0-9]+)(?:""&char(34)&"")""),D3*12),"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}