$re = '/^(?P<port>[1-9]{1,4}|[1-5][\d]{1,4}|6[0-5]{2}[0-3][0-5])$/m';
$str = '1
65536
65535';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);