const regex = new RegExp('^(?P<port>[1-9]{1,4}|[1-5][\\d]{1,4}|6[0-5]{2}[0-3][0-5])$', 'mg')
const str = `1
65536
65535`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}