// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http[s]?:\/\/)?([^\/\s]+\/)(.*)").unwrap();
let string = "http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}