package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http[s]?:\/\/)?([^\/\s]+\/)(.*)`)
var str = `http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}