use strict;
my $str = ' <Reference Include="DevExpress.Data.v14.1, Version=14.1.10.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
</Reference>';
my $regex = qr/(<Reference Include=")(DevExpress\.\D+\.v14\.1)(, Version=14\.1\.10\.0, Culture=neutral, PublicKeyToken=\S+, processorArchitecture=MSIL">)[\r\n\s]*(<SpecificVersion>False<\/SpecificVersion>)[\r\n\s]*(<\/Reference>)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}