const regex = /(<Reference Include=")(DevExpress\.\D+\.v14\.1)(, Version=14\.1\.10\.0, Culture=neutral, PublicKeyToken=\S+, processorArchitecture=MSIL">)[\r\n\s]*(<SpecificVersion>False<\/SpecificVersion>)[\r\n\s]*(<\/Reference>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<Reference Include=")(DevExpress\\.\\D+\\.v14\\.1)(, Version=14\\.1\\.10\\.0, Culture=neutral, PublicKeyToken=\\S+, processorArchitecture=MSIL">)[\\r\\n\\s]*(<SpecificVersion>False<\\\/SpecificVersion>)[\\r\\n\\s]*(<\\\/Reference>)', '')
const str = ` <Reference Include="DevExpress.Data.v14.1, Version=14.1.10.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
</Reference>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}