const regex = /\D+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D+', '')
const str = `8 %`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);