using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D+";
string substitution = @"";
string input = @"8 %";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}