# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"podEventRow[^>]+>(\s*<div class=\"[^>]+>\s*(<span[^>]+>|</span>|</?em>|[\s0-9/,.+-]+)+[^<]*</div>\s*)+</div>"
test_str = ("<div class=\"podEventRow singleRow\" data-plbtid=\"50139\">\n"
" <div class=\"wideLeftColumn centered\"><em>4.0, 4.5</em></div>\n"
" <div class=\"priceColumn third \" data-nav=\"pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25\" data-displayorder=\"27\">6.400</div>\n"
" <div class=\"priceColumn third \" data-nav=\"pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25\" data-displayorder=\"28\">1.115</div>\n"
" </div>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.