use strict;
my $str = '<div class="podEventRow singleRow" data-plbtid="50139">
<div class="wideLeftColumn centered"><em>4.0, 4.5</em></div>
<div class="priceColumn third " data-nav="pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25" data-displayorder="27">6.400</div>
<div class="priceColumn third " data-nav="pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25" data-displayorder="28">1.115</div>
</div>';
my $regex = qr/<div class="podEventRow[^>]+>(\s*<div class="[^>]+>\s*(<span[^>]+>|</span>|</?em>|[\s0-9/,.+-]+)+[^<]*</div>\s*)+</div>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}