const regex = /{\$(\w+|\w+\|\w+)}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{\\$(\\w+|\\w+\\|\\w+)}', 'g')
const str = `<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta name="robots" content="index,follow">
<meta name="keywords" content="kamerki, erotyczne">
<meta name="description" content="Eroticam.pl">
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
<title>Strona główna | Eroticam.pl</title>
<base href="{\$_template_root|small_letters}">
<meta property="og:url" content="{\$_template_root}"/>
<meta property="og:site_name" content="eroticam.pl"/>
<meta property="og:title" content="Strona główna | Eroticam.pl"/>
<meta property="og:type" content="profile"/>
<meta property="og:image" content="/img/logo_big.jpg" />
<meta property="og:description" content="Opis strony"/>
<script src="{\$_template_root}/js/libs/console.js"></script>
<script src="{\$_template_root}/js/libs/broadcast.js"></script>
<script src="https://cdn.socket.io/socket.io-1.3.5.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/jquery-ui.min.js"></script>
<script src="{\$_template_root}/js/jquery.fancybox.pack.js"></script>
<link rel="stylesheet" href="{\$_template_root}/css/components.css">
<link rel="stylesheet" href="{\$_template_root}/css/default/style.css">
<link rel="stylesheet" href="{\$_template_root}/css/default/responsive.css">
<link rel="stylesheet" href="{\$_template_root}/css/jquery.fancybox.css">
<link rel="stylesheet" href="{\$_template_root}/css/unoSlider.css" type="text/css" media="screen" />
<link rel="stylesheet" href="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/themes/smoothness/jquery-ui.css" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="google-site-verification" content="1tqMv6H9GEsFbXTZaW8zcngUGvqorZ94csA1v7Nc2qg" />
</head>
<body>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}