import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\$(\\w+|\\w+\\|\\w+)\\}";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<head>\n"
+ " <meta charset=\"utf-8\">\n"
+ " <meta name=\"robots\" content=\"index,follow\">\n"
+ " <meta name=\"keywords\" content=\"kamerki, erotyczne\">\n"
+ " <meta name=\"description\" content=\"Eroticam.pl\">\n"
+ " <link rel=\"shortcut icon\" href=\"/favicon.ico\" type=\"image/x-icon\">\n"
+ " <title>Strona główna | Eroticam.pl</title>\n"
+ " <base href=\"{$_template_root|small_letters}\">\n"
+ " <meta property=\"og:url\" content=\"{$_template_root}\"/>\n"
+ " <meta property=\"og:site_name\" content=\"eroticam.pl\"/>\n"
+ " <meta property=\"og:title\" content=\"Strona główna | Eroticam.pl\"/>\n"
+ " <meta property=\"og:type\" content=\"profile\"/>\n"
+ " <meta property=\"og:image\" content=\"/img/logo_big.jpg\" />\n"
+ " <meta property=\"og:description\" content=\"Opis strony\"/>\n"
+ " \n"
+ " <script src=\"{$_template_root}/js/libs/console.js\"></script>\n"
+ " <script src=\"{$_template_root}/js/libs/broadcast.js\"></script>\n"
+ " <script src=\"https://cdn.socket.io/socket.io-1.3.5.js\"></script>\n"
+ " <script src=\"//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js\"></script>\n"
+ " <script src=\"//ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/jquery-ui.min.js\"></script>\n"
+ " <script src=\"{$_template_root}/js/jquery.fancybox.pack.js\"></script>\n"
+ " \n"
+ " <link rel=\"stylesheet\" href=\"{$_template_root}/css/components.css\">\n"
+ " <link rel=\"stylesheet\" href=\"{$_template_root}/css/default/style.css\">\n"
+ " <link rel=\"stylesheet\" href=\"{$_template_root}/css/default/responsive.css\">\n"
+ " <link rel=\"stylesheet\" href=\"{$_template_root}/css/jquery.fancybox.css\">\n"
+ " <link rel=\"stylesheet\" href=\"{$_template_root}/css/unoSlider.css\" type=\"text/css\" media=\"screen\" />\n"
+ " <link rel=\"stylesheet\" href=\"//ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/themes/smoothness/jquery-ui.css\" />\n"
+ " \n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1\">\n"
+ " <meta name=\"google-site-verification\" content=\"1tqMv6H9GEsFbXTZaW8zcngUGvqorZ94csA1v7Nc2qg\" />\n"
+ "</head>\n"
+ "<body>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}