$re = '/^\w+\b/';
$str = 'time -format long -other fak';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);