package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+\b`)
var str = `time -format long -other fak`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}