$re = '/^[0-9]{8}\-[A-Z]$/';
$str = '03447712-N';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);