package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{8}\-[A-Z]$`)
var str = `03447712-N`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}