$re = '/(^1\|.*)|(.*\|1\|.*)|(.*\|1$)/m';
$str = '|2|221|3|4|5|6|1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);