package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^1\|.*)|(.*\|1\|.*)|(.*\|1$)`)
var str = `|2|221|3|4|5|6|1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}