# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/tenor\.com\/(?:[a-z]{2}(?:-[A-Z]{2})?\/)?view\/(?P<image_slug>[a-zA-Z0-9%-]+-(?P<image_id>\d+))"
test_str = ("https://tenor.com/es-ES/view/baka-idiot-anime-gif-16811539\n"
"https://tenor.com/bg/view/baka-idiot-anime-gif-16811539\n"
"https://tenor.com/de/view/baka-idiot-anime-gif-16811539\n"
"https://tenor.com/zh-CN/view/baka-idiot-anime-gif-16811539\n"
"https://tenor.com/view/frieren-%E8%91%AC%E9%80%81%E3%81%AE%E3%83%95%E3%83%AA%E3%83%BC%E3%83%AC%E3%83%B3-sousou-no-frieren-sousou-beyond-journey%27s-end-gif-13214487266596803271")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.