import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/tenor\\.com\\/(?:[a-z]{2}(?:-[A-Z]{2})?\\/)?view\\/(?P<image_slug>[a-zA-Z0-9%-]+-(?P<image_id>\\d+))";
final String string = "https://tenor.com/es-ES/view/baka-idiot-anime-gif-16811539\n"
+ "https://tenor.com/bg/view/baka-idiot-anime-gif-16811539\n"
+ "https://tenor.com/de/view/baka-idiot-anime-gif-16811539\n"
+ "https://tenor.com/zh-CN/view/baka-idiot-anime-gif-16811539\n"
+ "https://tenor.com/view/frieren-%E8%91%AC%E9%80%81%E3%81%AE%E3%83%95%E3%83%AA%E3%83%BC%E3%83%AC%E3%83%B3-sousou-no-frieren-sousou-beyond-journey%27s-end-gif-13214487266596803271";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}