$re = '/[A-Z]{1}\S{1,3} [0-9]{1}\w{2}/m';
$str = 'SW1A 2AA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);