package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{1}\S{1,3} [0-9]{1}\w{2}`)
var str = `SW1A 2AA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}