package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\D\.\s\-]{1,}[\s]?)(([\d]{1,3}[\s\-\,]?[\D]?+)+)`)
var str = `Josef-Fehler-Str. 11,12,13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}