using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\D\.\s\-]{1,}[\s]?)(([\d]{1,3}[\s\-\,]?[\D]?+)+)";
string input = @"Josef-Fehler-Str. 11,12,13";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}