import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<time>\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d+) \\[(?<loglevel>\\w)\\] (?<message>.*)";
final String string = "2020-04-30 08:26:09.379 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (\"\"): (:) \n"
+ " ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df setStatus mit Status: (I:kernel#0) \n\n"
+ "2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (\"\"): (:) \n"
+ " ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df creating status gui object for stepper\n\n"
+ "2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (\"\"): (:) \n"
+ " ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df transfer object for status set created!\n\n"
+ "2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.queue.OutputQueue 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (\"\"): (:) \n"
+ " ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df +++++ adding request to queue:\n"
+ "##### Transfer Object Output\n"
+ "StatusID: 0(OK)\n"
+ "SourceID: 3(GUI/Poll result)\n"
+ "FunctionID/SubFunctionID: 10/-1\n"
+ "(SetStatus)\n"
+ "RequestAgainHint false\n"
+ "SessionID null\n"
+ "TypTransferObject class de.icongmbh.dope.gui.web.DOPEGuiStatus\n"
+ "ArrayTransferObjects null\n"
+ "##### Transfer Object Output Ends\n\n"
+ "2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.queue.OutputQueue 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (\"\"): (:) \n"
+ " ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df Added request to queue, request list size: 7 (0|3|201|-1 / 0|3|19|-1 / 0|3|7|0 / 0|3|5000|-1 / 0|3|19|-1 / 0|3|20|1 / 0|3|10|-1 / )\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}