#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<time>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+) \[(?<loglevel>\w)\] (?<message>.*)"
Local $sString = "2020-04-30 08:26:09.379 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (""): (:) " & @CRLF & _
" ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df setStatus mit Status: (I:kernel#0) " & @CRLF & _
"" & @CRLF & _
"2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (""): (:) " & @CRLF & _
" ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df creating status gui object for stepper" & @CRLF & _
"" & @CRLF & _
"2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.DopeWebGui 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (""): (:) " & @CRLF & _
" ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df transfer object for status set created!" & @CRLF & _
"" & @CRLF & _
"2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.queue.OutputQueue 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (""): (:) " & @CRLF & _
" ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df +++++ adding request to queue:" & @CRLF & _
"##### Transfer Object Output" & @CRLF & _
"StatusID: 0(OK)" & @CRLF & _
"SourceID: 3(GUI/Poll result)" & @CRLF & _
"FunctionID/SubFunctionID: 10/-1" & @CRLF & _
"(SetStatus)" & @CRLF & _
"RequestAgainHint false" & @CRLF & _
"SessionID null" & @CRLF & _
"TypTransferObject class de.icongmbh.dope.gui.web.DOPEGuiStatus" & @CRLF & _
"ArrayTransferObjects null" & @CRLF & _
"##### Transfer Object Output Ends" & @CRLF & _
"" & @CRLF & _
"2020-04-30 08:26:09.381 [I] DOPiX de.icongmbh.dope.gui.web.queue.OutputQueue 32.2.4 (22323279) debug J00000000003-aa67ca3ef26946349158ec2da0216758 (""): (:) " & @CRLF & _
" ### GUI J00000000002-7a8d7048a4f94b78a8a5c24341d763df Added request to queue, request list size: 7 (0|3|201|-1 / 0|3|19|-1 / 0|3|7|0 / 0|3|5000|-1 / 0|3|19|-1 / 0|3|20|1 / 0|3|10|-1 / )" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")