re = /(?<!^\s*)(?=<GTOL-[A-Z]+>)/m
str = '<GTOL-POSI>.010<MOD-MMC>B-C<GTOL-POSI>.002<MOD-FMC>
<GTOL-POSI><MOD-DIAM>.004<MOD-MMC>HC<MOD-MMC><GTOL-POSI>.030<MOD-MMC>D-E<MOD-FMC>
<GTOL-POSI><MOD-DIAM>.005<MOD-MMC>AD-E<MOD-MMC><GTOL-PERP>.001A'
subst = '\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result