$re = '/<([^\s]+)>(.*)<\/\1>/';
$str = '<title>hello <link>what</link> </title>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);