using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^\s]+)>(.*)<\/\1>";
string input = @"<title>hello <link>what</link> </title>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}