import Foundation
let pattern = #"^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Valid emails:
user@domain.ru
na_me.lastname@subdomain.domain.ru
name-lastname@7.sub-sub-domain.subdomain.domain.ru
ni+ck'name-name.lastname@d.oma-in-domain.ru
Invalid addresses in the user section:
.user@domain.ru
user.@domain.ru
-user@domain.ru
user-@domain.ru
us..er@domain.ru
us--er@domain.ru
Invalid addresses in the domain section:
user@-domain.ru
user@.subdomain.domain.ru
user@subdomain-.domain.ru
user@subdomain..domain.ru
user@domain.-domain.ru
user@dom--ain.ru
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)