// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$").unwrap();
let string = "Valid emails:
user@domain.ru
na_me.lastname@subdomain.domain.ru
name-lastname@7.sub-sub-domain.subdomain.domain.ru
ni+ck'name-name.lastname@d.oma-in-domain.ru
Invalid addresses in the user section:
.user@domain.ru
user.@domain.ru
-user@domain.ru
user-@domain.ru
us..er@domain.ru
us--er@domain.ru
Invalid addresses in the domain section:
user@-domain.ru
user@.subdomain.domain.ru
user@subdomain-.domain.ru
user@subdomain..domain.ru
user@domain.-domain.ru
user@dom--ain.ru";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}