use strict;
my $str = 'UDP request from 20.0.1.42:34315 to 8.8.8.8:53. Action: Allow. Rule Collection: wfx-us-east-prod-allow-internet. Rule: allow-internet
TCP request from 162.158.79.116:45646 to 52.191.237.198:443 was DNAT\'ed to 20.0.1.28:443. Rule Collection: wfx-us-east-prod-nat-rules. Rule: collector-02}}';
my $regex = qr/(?P<protocol>\w+)\s*request\s*from\s*(?P<source_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<source_port>\d+)\s*to\s*(?P<destination_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<destination_port>\d+).\s*was\s*DNAT'ed\s*to\s*(?P<post_nat_ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<post_nat_destination_port>\d+).\s*Rule\s*Collection:\s*(?P<rule_collection>[^\s.]+).\s*Rule:\s*(?P<rule>[^\s}]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}