package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<protocol>\w+)\s*request\s*from\s*(?P<source_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<source_port>\d+)\s*to\s*(?P<destination_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<destination_port>\d+).\s*was\s*DNAT'ed\s*to\s*(?P<post_nat_ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<post_nat_destination_port>\d+).\s*Rule\s*Collection:\s*(?P<rule_collection>[^\s.]+).\s*Rule:\s*(?P<rule>[^\s}]+)`)
var str = `UDP request from 20.0.1.42:34315 to 8.8.8.8:53. Action: Allow. Rule Collection: wfx-us-east-prod-allow-internet. Rule: allow-internet
TCP request from 162.158.79.116:45646 to 52.191.237.198:443 was DNAT'ed to 20.0.1.28:443. Rule Collection: wfx-us-east-prod-nat-rules. Rule: collector-02}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}