$re = '/<div\sid=\"imgTagWrapperId[\s\S]*?,"([\s\S]*?)"/m';
$str = '<div id="imgTagWrapperId" class="imgTagWrapper" style="height: 373.333px;">
<img alt="New Balance Women\'s FuelCore Agility v2 Cross Trainer, Black, 8 B US" src="https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX575_.jpg" data-old-hires="https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UL1500_.jpg" class="a-dynamic-image a-stretch-horizontal" id="landingImage" data-a-dynamic-image="{"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX695_.jpg":[396,695],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX500_.jpg":[285,500],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX575_.jpg":[328,575],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX535_.jpg":[305,535],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX395_.jpg":[225,395],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX675_.jpg":[385,675],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX625_.jpg":[356,625]}" style="max-width: 448px; max-height: 255.263px;">
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);