#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div\sid=\"imgTagWrapperId[\s\S]*?,"([\s\S]*?)""
Local $sString = "<div id="imgTagWrapperId" class="imgTagWrapper" style="height: 373.333px;">" & @CRLF & _
" <img alt="New Balance Women's FuelCore Agility v2 Cross Trainer, Black, 8 B US" src="https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX575_.jpg" data-old-hires="https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UL1500_.jpg" class="a-dynamic-image a-stretch-horizontal" id="landingImage" data-a-dynamic-image="{"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX695_.jpg":[396,695],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX500_.jpg":[285,500],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX575_.jpg":[328,575],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX535_.jpg":[305,535],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX395_.jpg":[225,395],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX675_.jpg":[385,675],"https://images-na.ssl-images-amazon.com/images/I/81IJpkf3s4L._UX625_.jpg":[356,625]}" style="max-width: 448px; max-height: 255.263px;">" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")