$re = '/^.+?\/[sites|2023|sites\/3].*$/m';
$str = 'uploads/sites\\3/2022';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);