package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+?\/[sites|2023|sites\/3].*$`)
var str = `uploads/sites\3/2022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}