$re = '/\[.\]
/';
$str = '[2] O. Y. Abramov, “Industry Best Practices And The Role Of TRIZ In Developing New Products,” in ResearchGate, 2013.
[3] D. Cavallucci, S. Fuhlhaber, and A. Riwan, “Assisting Decisions in Inventive Design of Complex Engineering Systems,” Procedia Eng., vol. 131, pp. 975–983, 2015.
[4] W. Yan, H. Liu, C. Zanni-Merk, and D. Cavallucci, “IngeniousTRIZ: An automatic ontology-based system for solving inventive problems,” Knowl.-Based Syst., vol. 75, pp. 52–65, Feb. 2015.
[5] B.Campbell,“Brainstorming and TRIZ,” TRIZ J., 2003. February,http://www.triz journal.com/archives/2003/02/index.htm.
[6] A. Aamodt and E. Plaza, “Case-based reasoning: Foundational issues, methodological variations, and system approaches,” AI Commun., vol. 7, no. 1, pp. 39–59, 1994.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);